Sep. 24, 2018

Hello der,  Guest
Trader Name:
Password:
 | Home | Forum List | Active Threads | Search:
Page: of 1   
TWX Development > 2.04 DataBase Issue  
<< Thread >>
Subscribed:  
TheBountyHunter


Joined: Nov 2005

posted: 05/31/2006 at 02:54 AM Post #1

I was running 3 instances of twx for 3 games.  On the 3rd game I created a database for a 10k game that was really a 20k game.  As soon as I got into the game I was droped into a sector > 10k.  Got the can't store sector error.  That instantly corrupted the data base.  I deleted it nad tried to make a new one but got a corrumpted message every time I tried to make a new data base.  So I exited twx and tried again.  Same message.  So I end all 3 sessions of TWX, start 1 inscance of it and same message.  I then closed down that twx and started a new session.  I tried to use one of my current databases.  When I tried to connect I got you must use an un-corrupted database.  Happen with every game dtatbase I was playing.  Next I tried deleteing the twx.dat file and "resetting" twx.  No luck.  I deleted the data directory and made a new directory and all of a sudden everything was just fine.  Also after the error occured with the ector >10k.  When I tried to close down that instance I got a shutdown error for that program and the little bot to send or not send data to microsoft.
ElderProphet
TWX Development Team

Joined: Mar 2005

posted: 05/31/2006 at 05:58 AM Post #2

I've noticed that if I try to delete and then create a database of the same name, it fails.  In the data directory, there's an .xdb and .cfg file associated with each database, and both of those have to be deleted to truly remove the old database.  I'll see if I can get that fixed soon.

One database being corrupted should not affect any other TWX session.  Are you saying that this occurred?

+EP+

Haggle Blog-> http://jroller.com/page/ElderProphet
TheBountyHunter


Joined: Nov 2005

posted: 05/31/2006 at 07:15 AM Post #3

Yes.  After the created database was corrupted I deleted it and shut down twx and restarted.  I then tried to connect to one of the games I had been playing and then I double-clicked the twx icon to connect I got a error message that you must us a un-corrupted database.  Tried it with all 3 of the games I was playing with and said it with all 3 of them.
Traitor
Admin of THE tw
info site


Joined: Mar 2005

posted: 05/31/2006 at 07:43 AM Post #4

That would happen in 2.03 as well, and I think even in 2.02. 
once you get a hosed DB, you need to delete the bad files.  What happens when you load TWX is it scans all the DB's.  If any are bad, it can make TWX unstable until those files are removed, and TWX is restarted.  After that, you should be able to use your old DB's again.

edited by: traitor on 05/31/2006 at 07:44 AM

Visit www.tw-cabal.com!
TWX Development >  2.04 DataBase Issue
<< Thread >>
Subscribed:  
 | Home | Forum List | Active Threads | Search:
Page: of 1   

"why hello der matey! have a sit and buy me an ale, eh?" -- The Grimy Old Trader

The Grimy Trader is best viewed at 1024x768 resolution -- this page was generated in: 0.353 seconds.